Language

Having trouble? Something not working as it should? Look here.
Post Reply
lostinthe50s
Posts: 3
Joined: Thu Apr 07, 2016 12:45 pm

Language

Post by lostinthe50s » Thu Apr 07, 2016 12:59 pm

I use SearchTempest frequently and recently have experienced a series of errors where the results are shown in a foreign language. This does not appear in the search results but only occurs once I click on a specific listing. Here is an example http://kansascity.craigslist.org/pts/54 ... ml?lang=sv. I've tried to substitute an e for english at the end of the string to change it to english, sometimes it works and sometimes it doesn't. I'm running Windows 7 Professional, Service Pack 1 and Mozilla Firefox 45.0.1

User avatar
Tempest Nathan
Site Admin
Posts: 1368
Joined: Fri Apr 18, 2008 10:06 pm
Contact:

Re: Language

Post by Tempest Nathan » Thu Apr 07, 2016 1:15 pm

Could you send me the link to your searchtempest results page? Our code should be filtering out those lang parameters, so I'm not sure how it ended up there. Thanks!


User avatar
Tempest Nathan
Site Admin
Posts: 1368
Joined: Fri Apr 18, 2008 10:06 pm
Contact:

Re: Language

Post by Tempest Nathan » Thu Apr 07, 2016 3:41 pm

Huh, that ad doesn't appear under Kansas City for me using that search. Maybe it's been deleted?

Anyway, the language code for English is 'en', not 'e', so maybe if you change it to 'en' it will fix it, and hopefully remember the selection for future ads. I'm only really guessing how that code ended up on the url, since I did check and we don't have language codes on any of our outgoing links, so I can only assume it was added once you got to craigslist. (And since we don't have any affiliation with craigslist, we have no control over what happens once you get to their site.)

lostinthe50s
Posts: 3
Joined: Thu Apr 07, 2016 12:45 pm

Re: Language

Post by lostinthe50s » Thu Apr 07, 2016 4:32 pm

Thanks. I'll try it.

Molligano
Posts: 1
Joined: Wed Aug 31, 2016 1:09 am

Re: Language

Post by Molligano » Wed Aug 31, 2016 11:21 pm

Tempest Nathan wrote:Huh, that ad doesn't appear under Kansas City for me using that search. Maybe it's been deleted?

Anyway, the language code for English is 'en', not 'e', so maybe if you change it to 'en' it will fix it, and hopefully remember the selection for future ads. I'm only really guessing how that code ended up on the url, since i bought a hydromax x30 I did check and we don't have language codes on any of our outgoing links, so I can only assume it was added once you got to craigslist. (And since we don't have any affiliation with craigslist, we have no control over what happens once you get to their site.)
Ah so that's it. You're right Craigslist automatically ads language codes to their urls for some reason. Changing to 'en' fixes it.

Post Reply