Craigslist search parameters

Archived. You can get help or offer suggestions about AutoTempest here.
Locked
secretnarwhal
Posts: 2
Joined: Wed Mar 12, 2014 11:51 am

Craigslist search parameters

Post by secretnarwhal » Wed Mar 12, 2014 12:06 pm

On your Autotempest site, starting about a month ago, the date parameters I set don't work under the craigslist tab. If I search, say all Fords 1962-1965, it will work perfectly in every tab except craiglist, where it will search all Fords regardless of date. This only happens with the date parameters- all others work in all tabs. Any suggestions on how to fix this?

User avatar
Tempest Nathan
Site Admin
Posts: 1371
Joined: Fri Apr 18, 2008 10:06 pm
Contact:

Re: Craigslist search parameters

Post by Tempest Nathan » Wed Mar 12, 2014 12:33 pm

As far as I can tell, this is the result of a very strange Google bug. By default the craigslist results are powered by Google. When you enter a range of years, we translate them into keywords. So we're actually searching for "(1962 OR 1963 OR 1964 OR 1965)". For some incomprehensible reason, lately Google has been ignoring the year keywords, for some users only. And unfortunately they don't tend to respond to bug reports for search.

You do have a couple of alternatives. The easiest one would be, in the craigslist tab, to change the "Sort by" box to "Best Match". The Best Match sort returns all results in a single list, and is powered by Yahoo instead of Google, so presumably it won't have this problem. The other option would be to switch to Direct Results mode in the craigslist tab. It would definitely get you the right results, but is a bit more cumbersome, especially on mobile devices. More info on that here: http://www.searchtempest.com/faq.php#directresults

I hope that helps! I'm also going to try mucking around with the formatting we use for the Google search just to see if we can get it to follow a different code path or something and avoid this bug. :S

User avatar
Tempest Nathan
Site Admin
Posts: 1371
Joined: Fri Apr 18, 2008 10:06 pm
Contact:

Re: Craigslist search parameters

Post by Tempest Nathan » Wed Mar 12, 2014 12:35 pm

BTW: If you could email me the link to your results page, that might help me track down the problem. Unfortunately all these searches are working properly for me, so it's a bit tough to debug. :roll:

secretnarwhal
Posts: 2
Joined: Wed Mar 12, 2014 11:51 am

Re: Craigslist search parameters

Post by secretnarwhal » Thu Mar 13, 2014 2:20 pm

I've tried both of the solutions you suggested, but my results are still all cars that fit the criteria regardless of year range. Will I just have to wait until this problem is fixed?

User avatar
Tempest Nathan
Site Admin
Posts: 1371
Joined: Fri Apr 18, 2008 10:06 pm
Contact:

Re: Craigslist search parameters

Post by Tempest Nathan » Thu Mar 13, 2014 2:33 pm

secretnarwhal wrote:I've tried both of the solutions you suggested, but my results are still all cars that fit the criteria regardless of year range. Will I just have to wait until this problem is fixed?
I replied to your email requesting more information.

I can't imagine why you'd be having the same problem with Direct Results mode though, since the results there come straight from craigslist, just as if you'd searched manually. Perhaps the unexpected results have the year keyword in a different context? For example, "1990 Ford Contour ... Call 555-555-1964"?

Locked